Wacom Graphire2 driver for Solaris

Wacom USB Graphire 2 tablet driver binaries (May 15th, 2003)

Binary package for Sol8 x86(v0.9.3) (see note #1 below)
NEW Binary package for Sol8 sparc(v0.9.2)

Once you have downloaded the package, do
pkgadd -d BOLTwtblt*.pkg
and you will then be able to use programs that are XINPUT aware.

Unfortunately, there arent many. The two I have found are gsumi, and The GIMP

Critical Note #1

If upgrading from the original version (if 'pkginfo -l BOLTwtblt' says you have version 0.9 installed), make a backup of /usr/openwin/server/etc/OWconfig before doing pkgrm BOLTwblt . After pkgrm is complete, if the original file is no longer there, copy the backup over, and hand-edit out the bits at the bottom about BOLTwacom.
This should not be neccessary if you already have v0.9.1 or later.

Critical Note #2

The driver only allows use of the tablet as a secondary device. You will need a regular mouse, in addition to the tablet hardware, to use X normally. The good news is, you will be able to use the graphire2 pen, eraser, AND 'mouse', as separate brushes. I sugest using the 'eraser' for a brush, and the mouse as an eraser

Critical Note #3

Do not remove the tablet from the system while the Xserver is running, or you may crash your system.

Critical Note #4

There is a murky problem with Solaris 9, where opening the device may crash your system. If this happens to you, but you are still interested in trying to use the tablet, try using it in another slot. It may work for you. Any particular slot seems to be "crash 100% of the time", or "works 100%", with current testing. When the crash issue is resolved, either with an OS patch, or a patch to the driver, this space will be updated appropriately.

Enabling XINPUT devices

'gsumi' works great out of the box, once you use "File->Input Dialog" menu to select the TABLET to mode=Window.

Unfortunately, there is some wierdness with 'gimp', where it grabs the pointer once you press down on the pen, and wont let you move it until you release. So you can only make dots, until you apply a patch.

To use gimp successfully, you will need to do one of the following proceedures:

Option 1: Recompile gtk and gimp

  [First, recompile libgtk to enable xinput, with --with-xinput=xfree. Then...]
  Download and extract gimp-1.2.3
  Apply this patch, with
    $ cd gimp-1.2.3/app ; patch -c  < /tmp/gimp-1.2.3.diffs
 
For the record, I belive this to be a bug in the gimp, (or possibly Xsun) not a bug in my driver. I hope the gimp team will release an 'official' patch for gimp1.2.x. But if someone would take the time to point out to me something that my driver is doing wrong, I'll be happy to take a stab at fixing it.

Option 2: Use precompiled binaries

Go to http://www.opencsw.org, find your nearest mirror site, and download the binaries :-)


Gimp configuration tips
Once you have gimp running, you will have to use the Menu
 File->Dialogs->Input Devices
 
to set the mode for each tablet device to 'Window'. Then use
 File->Dialogs->Device Status
to set the 'brush' for your pen, eraser, and tablet mouse.

Make sure to save in both the Input_Devices dialog,and the Device_Status dialog. Then quit and restart gimp. It should then properly respond to tablet input, while your main mouse pointer is in the drawing window.

XINPUT test proggie

If you're wondering whether your setup is actually working, or whether your problems are with the X-server, or gtk, or ...
I have written a trivial little program to test the XINPUT devices:
xopen.c

Source code

The source code comes in two pieces: The low-level "talk to the hardware" driver, and the Xsun XINPUT module that translates the datastream into XINPUT events.

The low-level driver is now a STREAMS driver, since for some reason, the Xsun ddx module just didnt seem to work unless it was talking to a STREAMS driver.


Bolthole Top - Solaris Pages - Driver Pages - Search Bolthole.com
Written by:Philip Brown